Sunday, 18 November 2007

Pitch Spelling Algorithms

Pitch Spelling Algorithms
Pitch spelling algorithm is the process of assigning appropriate pitch names that are consistent with the key context to numeric representations of pitch, such as, MIDI or pitch class numbers.

-Cambouropoulos
They introduce two new notions of approximate matching with application in computer assisted music analysis and also present algorithms for each notion of approximation: for approximate string matching and for computing approximate squares.

-Chew and Chen
The algorithm is spiral array model.

Sunday, 11 November 2007

Introduction to Acquisition Process

1. Serial search
-The algorithm tests the cells one by one.
-The cell corresponds to the correct code-phase and Doppler of the acquired signal within a given resolution.
2. Parallel search
In this architecture the test statistics are generated over the entire search.
3. Hybrid
With the hybrid search strategy the whole search is divided into a number of test regions each consisting of a few cells.

Introduction to Fourier Optics

Aperture effect
When the incident wave goes through an aperture, the observed field is the combination. If a distant object is viewed through a small circular aperture that is placed close to the eye, there is an apparent "shadowing" of the center of the viewed image, while the inner perimeter of the aperture is bright.

What is Fourier Optics?(quoted from http://www.fourieroptics.org.uk/ )
Fourier optics describes the propagation of light using Fourier analysis. It can be used to describe Fresnel and Fraunhofer diffraction. The Fraunhofer diffraction pattern is the Fourier transform of the diffracting object.
Fresnel diffraction describes the diffracted light field a large distance away from the object compared to the wavelength of light, but not so large the curvature of the wavefront can be neglected. Fraunhofer diffraction describes the diffracted light field a large distance away from the object such that the curvature of the wavefront can be neglected.
Possible uses are:
• Describing image formation
• Modelling the aberrations of an optical system
• Studying the performance of a lens
• Modelling diffraction patterns and light propagation
• Optical signal processing
• Optical computing

Tuesday, 9 October 2007

Introduction to trust in CRN

quoted from BWN lab


CRN: Cognitive Radio Network
Cognitive Radio:
1. It knows the current degree of needs and future likelihood of needs of its users.
2. Learns and recognizes usage patterns from users.

Cognitive Radio Capability
1. Reconfigurable
2. Cognitive

CRN
1. Primary system (including licensed band and unlicensed band)
2. Cognitive radio system

The Definition of Trust
1. Trust of a party X to a party Y for a specific services S is the measurable belief of X in that Y behaves dependably for a specified period.
2. Trust can be seen as a directional relationship between trustor and trustee.

Trust Categorization
1. Access trust
2. Data trust
3. Operations trust
4. Communication trust

Some properties of Trust
1. Transitivity
2. Asymmetry
3. Dynamic Changing
4. Multi-level

CRN will consist of multiple service providers, access network operators, and different kinds of terminals.

Thursday, 4 October 2007

Firefox and Jajah

The JAJAH extension for Firefox integrates call functionality into your browser. Phone numbers on web pages are automatically detected and highlighted. When clicked, JAJAH initiates a phone call from your phone...
The JAJAH extension for Firefox integrates call functionality into your browser. Phone numbers on web pages are automatically detected and highlighted. When clicked, JAJAH initiates a phone call from your phone
- landline or mobile - to the desired destination. Alternatively, phone numbers can be entered directly in the toolbar, thus effectively combining phone communication with everyday web browsing.

Regardless of your phone company or plan, JAJAH allows long distance and international calls for less than 2 cents a minute - no monthly fee, no registration fee, no need for prepayment. Trial users receive 5 free minutes to experience the outstanding quality and simplicity of the JAJAH service.

For more info please visit www.jajah.com

Tuesday, 4 September 2007

Optical Network

Although wireless communication is more and more popular and technologies that support high mobility and high data rate has been implemented such as WIMAX, 3.5G HSDPA, etc; wire network is truly the backbone of the Internet. Wire network like optical network has tremendous amounts of bandwidth and high data rate, no inter-symbol interference (ISI) and no inter-channel interference (ICI) while wireless communication is more convenient and can be set up on portable devices.

Thursday, 2 August 2007

Media Gateway Control Protocol


In computing, Media Gateway Control Protocol (MGCP) is a protocol used within a distributed Voice over IP system.

MGCP is defined in RFC 3435, which obsoletes an earlier definition in RFC 2705. It superseded the Simple Gateway Control Protocol (SGCP).

Another protocol for the same purpose is Megaco, a co-production of IETF (RFC 3525) and ITU (Recommendation H.248-1). Both protocols follow the guidelines of the API Media Gateway Control Protocol Architecture and Requirements at RFC 2805.
Contents

Architecture

The distributed system is composed of a Call Agent (or Media Gateway Controller), at least one Media Gateway (MG) that performs the conversion of media signals between circuits and packets, and at least one Signaling Gateway (SG) when connected to the PSTN.
The Call Agent uses MGCP to tell the Media Gateway:
what events should be reported to the Call Agent
how endpoints should be connected together
what signals should be played on endpoints.
MGCP also allows the Call Agent to audit the current state of endpoints on a Media Gateway.
The Media Gateway uses MGCP to report events (such as off-hook, or dialed digits) to the Call Agent.

(While any Signaling Gateway is usually on the same physical switch as a Media Gateway, this needn't be so. The Call Agent does not use MGCP to control the Signaling Gateway; rather, SIGTRAN protocols are used to backhaul signaling between the Signaling Gateway and Call Agent).

In MGCP, every command has a transaction ID and receives a response.
Typically, a Media Gateway is configured with a list of Call Agents from which it may accept programming (where that list normally comprises only one or two Call Agents). In principle, event notifications may be sent to different Call Agents for each endpoint on the gateway (as programmed by the Call Agents, by setting the NotifiedEntity parameter). In practice however, it is usually desirable that at any given moment all endpoints on a gateway should be controlled by the same Call Agent; other Call Agents are available only to provide redundancy in the event that the primary Call Agent fails, or loses contact with the Media Gateway. In the event of such a failure it is the backup Call Agent's responsibility to reprogram the MG so that the gateway comes under the control of the backup Call Agent. Care is needed in such cases; two Call Agents may know that they have lost contact with one another, but this does not guarantee that they are not both attempting to control the same gateway. The ability to audit the gateway to determine which Call Agent is currently controlling can be used to resolve such conflicts.
MGCP assumes that the multiple Call Agents will maintain knowledge of device state among themselves (presumably with an unspecified protocol) or rebuild it if necessary (in the face of catastrophic failure). Its failover features take into account both planned and unplanned outages.

Protocol Overview

MGCP packets are unlike what you find in many other protocols. Usually wrapped in UDP port 2427, the MGCP datagrams are formatted with whitespace, much like you would expect to find in TCP protocols. An MGCP packet is either a command or a response.
Commands begin with a four-letter verb. Responses begin with a three number response code.
There are eight (8) command verbs: AUEP, AUCX, CRCX, DLCX, MDCX, NTFY, RQNT, RSIP
Two verbs are used by a Call Agent to query (the state of) a Media Gateway: AUEP - Audit Endpoint

AUCX - Audit Connection

Three verbs are used by a Call Agent to manage an RTP connection on a Media Gateway (a Media Gateway can also send a DLCX when it needs to delete a connection for its self-management):
CRCX - Create Connection
DLCX - Delete Connection
MDCX - Modify Connection

One verb is used by a Call Agent to request notification of events on the Media Gateway, and to request a Media Gateway to apply signals:
RQNT - Request for Notification

One verb is used by a Media Gateway to indicate to the Call Agent that it has detected an event for which the Call Agent had previously requested notification of (via the RQNT command verb):
NTFY - Notify

One verb is used by a Media Gateway to indicate to the Call Agent that it is in the process of restarting:
RSIP - Restart In Progress
Goker