Tuesday, 9 October 2007

Introduction to trust in CRN

quoted from BWN lab


CRN: Cognitive Radio Network
Cognitive Radio:
1. It knows the current degree of needs and future likelihood of needs of its users.
2. Learns and recognizes usage patterns from users.

Cognitive Radio Capability
1. Reconfigurable
2. Cognitive

CRN
1. Primary system (including licensed band and unlicensed band)
2. Cognitive radio system

The Definition of Trust
1. Trust of a party X to a party Y for a specific services S is the measurable belief of X in that Y behaves dependably for a specified period.
2. Trust can be seen as a directional relationship between trustor and trustee.

Trust Categorization
1. Access trust
2. Data trust
3. Operations trust
4. Communication trust

Some properties of Trust
1. Transitivity
2. Asymmetry
3. Dynamic Changing
4. Multi-level

CRN will consist of multiple service providers, access network operators, and different kinds of terminals.

Thursday, 4 October 2007

Firefox and Jajah

The JAJAH extension for Firefox integrates call functionality into your browser. Phone numbers on web pages are automatically detected and highlighted. When clicked, JAJAH initiates a phone call from your phone...
The JAJAH extension for Firefox integrates call functionality into your browser. Phone numbers on web pages are automatically detected and highlighted. When clicked, JAJAH initiates a phone call from your phone
- landline or mobile - to the desired destination. Alternatively, phone numbers can be entered directly in the toolbar, thus effectively combining phone communication with everyday web browsing.

Regardless of your phone company or plan, JAJAH allows long distance and international calls for less than 2 cents a minute - no monthly fee, no registration fee, no need for prepayment. Trial users receive 5 free minutes to experience the outstanding quality and simplicity of the JAJAH service.

For more info please visit www.jajah.com

Tuesday, 4 September 2007

Optical Network

Although wireless communication is more and more popular and technologies that support high mobility and high data rate has been implemented such as WIMAX, 3.5G HSDPA, etc; wire network is truly the backbone of the Internet. Wire network like optical network has tremendous amounts of bandwidth and high data rate, no inter-symbol interference (ISI) and no inter-channel interference (ICI) while wireless communication is more convenient and can be set up on portable devices.

Thursday, 2 August 2007

Media Gateway Control Protocol


In computing, Media Gateway Control Protocol (MGCP) is a protocol used within a distributed Voice over IP system.

MGCP is defined in RFC 3435, which obsoletes an earlier definition in RFC 2705. It superseded the Simple Gateway Control Protocol (SGCP).

Another protocol for the same purpose is Megaco, a co-production of IETF (RFC 3525) and ITU (Recommendation H.248-1). Both protocols follow the guidelines of the API Media Gateway Control Protocol Architecture and Requirements at RFC 2805.
Contents

Architecture

The distributed system is composed of a Call Agent (or Media Gateway Controller), at least one Media Gateway (MG) that performs the conversion of media signals between circuits and packets, and at least one Signaling Gateway (SG) when connected to the PSTN.
The Call Agent uses MGCP to tell the Media Gateway:
what events should be reported to the Call Agent
how endpoints should be connected together
what signals should be played on endpoints.
MGCP also allows the Call Agent to audit the current state of endpoints on a Media Gateway.
The Media Gateway uses MGCP to report events (such as off-hook, or dialed digits) to the Call Agent.

(While any Signaling Gateway is usually on the same physical switch as a Media Gateway, this needn't be so. The Call Agent does not use MGCP to control the Signaling Gateway; rather, SIGTRAN protocols are used to backhaul signaling between the Signaling Gateway and Call Agent).

In MGCP, every command has a transaction ID and receives a response.
Typically, a Media Gateway is configured with a list of Call Agents from which it may accept programming (where that list normally comprises only one or two Call Agents). In principle, event notifications may be sent to different Call Agents for each endpoint on the gateway (as programmed by the Call Agents, by setting the NotifiedEntity parameter). In practice however, it is usually desirable that at any given moment all endpoints on a gateway should be controlled by the same Call Agent; other Call Agents are available only to provide redundancy in the event that the primary Call Agent fails, or loses contact with the Media Gateway. In the event of such a failure it is the backup Call Agent's responsibility to reprogram the MG so that the gateway comes under the control of the backup Call Agent. Care is needed in such cases; two Call Agents may know that they have lost contact with one another, but this does not guarantee that they are not both attempting to control the same gateway. The ability to audit the gateway to determine which Call Agent is currently controlling can be used to resolve such conflicts.
MGCP assumes that the multiple Call Agents will maintain knowledge of device state among themselves (presumably with an unspecified protocol) or rebuild it if necessary (in the face of catastrophic failure). Its failover features take into account both planned and unplanned outages.

Protocol Overview

MGCP packets are unlike what you find in many other protocols. Usually wrapped in UDP port 2427, the MGCP datagrams are formatted with whitespace, much like you would expect to find in TCP protocols. An MGCP packet is either a command or a response.
Commands begin with a four-letter verb. Responses begin with a three number response code.
There are eight (8) command verbs: AUEP, AUCX, CRCX, DLCX, MDCX, NTFY, RQNT, RSIP
Two verbs are used by a Call Agent to query (the state of) a Media Gateway: AUEP - Audit Endpoint

AUCX - Audit Connection

Three verbs are used by a Call Agent to manage an RTP connection on a Media Gateway (a Media Gateway can also send a DLCX when it needs to delete a connection for its self-management):
CRCX - Create Connection
DLCX - Delete Connection
MDCX - Modify Connection

One verb is used by a Call Agent to request notification of events on the Media Gateway, and to request a Media Gateway to apply signals:
RQNT - Request for Notification

One verb is used by a Media Gateway to indicate to the Call Agent that it has detected an event for which the Call Agent had previously requested notification of (via the RQNT command verb):
NTFY - Notify

One verb is used by a Media Gateway to indicate to the Call Agent that it is in the process of restarting:
RSIP - Restart In Progress
Goker

Wednesday, 18 July 2007

The Inspiration Of Ldpc Codes

The full name of LDPC code is low-density parity-check code, which means only few 1’s are shown on the parity-check matrix. For a linear block code, such as LDPC codes, we can find a fundamental decoding condition, cHT=0 where c is a code word and H is a parity-check matrix. If we do the matrix multiplication, we may get the following results. For example, c0+c1+c3=0; c3+c4+c7=0 where ci is the ith coded bit. Therefore, c0 is only influenced by c1 and c3.

Gallager proposed LDPC codes in 1962. The inspiration of LDPC codes is from less influence among different coded bits. For any code word, every coded bit can be corrected by two other bits assumed that there are three 1’s in a parity-check matrix row. If intrinsic information (received probability) doesn’t affect every coded bit, we can correct error bits through other extrinsic information (propagated probability). As block size increases, the coded bits become less correlated. Thus, we think of every coded bit as an independent bit and do an iterative algorithm called belief propagation. Finally, the decoded bits will be determined by both intrinsic information and extrinsic information.

http://www.shvoong.com/exact-sciences/engineering/electrical-engineering/communications-signal-processing/1630485-inspiration-ldpc-codes/

Sunday, 8 July 2007

Properties of LDPC Codes

1.Properties of LDPC Codes
1.1 Sparse Parity Matrix
A sparse matrix is a matrix populated with few ones in each row and column. More precisely, the ratio of nonzero entries into that matrix is kept low. This is the reason why they are called “low-density”. In particular, an (n,wc,wr) low-density-code is a code of block length n with a matrix like that of Fig..1 whose parity matrix has wc 1’s in each column, and wr 1’s in each row.


Fig. 1 low-density code matrix; N=20, wc =3, wr =4

1.2 Regular LDPC Codes
A regular LDPC code is a linear block code whose parity matrix H contains exactly wc 1’s in each column and wr = wc(n/n-k) 1’s in each row. The code rate is k/n and wc is extremely smaller than (n-k). Similarly, wr is extremely smaller than n. In [3], Markey shows that wc = 3 is necessary for good codes.

1.3 Irregular LDPC Codes
If the number of 1's per column or row is not constant, the code is an irregular LDPC code. It’s very easy to determine whether an LDPC code is regular or irregular through its graphical representation. Usually, irregular LDPC codes outperform regular LDPC codes.

2. Characteristics of LDPC Codes
In some specific situations, we can get the following characteristics.
2.1 Large dmin
Some facts can help LDPC codes achieve this goal. First, any two columns have an overlap of at most one 1. Secondly, the sparse property allows us to avoid over-lapping. Less over-lapping means high independence among different coded bits. The condition makes LDPC decoder good decoding ability and low bit error rate.

2.2 Low Complexity
The "Low Density" characteristic only applies to the H matrix (i.e., the parity check matrix). H matrix is a decision criterion and represents decoding algorithm. Thus, lower density in the H matrix yields low-complexity in the decoder.

3 Advantage of LDPC codes
3.1 Near-capacity Performance
Shannon's theory tells us that “long” and “random” codes achieve capacity. LDPC codes provide the solution and attain near-capacity performance. However, it doesn’t mean that an LDPC code is the best code. Different codes are good at different things. For example, Turbo Codes are better at low code rates, i.e., R = 1/2 and below.

We know that irregular LDPC codes have better performance than regular LDPC codes. Therefore, the key to a good LDPC code is how to design it. There are methodical procedures for designing LDPC codes, especially irregular ones. [4] proposes a class of efficiently encodable irregular LDPC codes which might be called extended IRA codes.

Wednesday, 27 June 2007

LDPC Codes History

The history of coding starts with the seminal work of Claude Shannon on the mathematical theory of communication in 1948. He demonstrated that errors induced by a noisy channel can be reduced to any desired level as long as the information rate is less than the capacity of the channel. The theoretical maximum information transfer rate is called Shannon limit.

In 1962, Gallager proposed a low-density parity-check code in his doctoral dissertation. LDPC codes are defined by a sparse parity-check matrix. They provided near-capacity performance but difficult implementation. Also, the concatenated RS and convolutional codes were considered perfectly suitable for error control coding. Thus, his remarkable thesis was forgotten by coding researchers for almost 20 years. In 1981, Tanner generalized LDPC codes and created a bipartite graph used to represent those codes. However, it was still ignored by coding theorists.

LDPC codes were noticed again by some researchers in the mid-1990’s. They began to investigate codes on graph and iterative decoding. Markey and other researchers discovered the advantage between linear block codes which generated by sparse matrix and iterative decoding based on belief propagation. And by that time the decoding complexity looked achievable. Since that time, a lot of papers have been published and LDPC has become popular so far.